Buy

Compatibility

How to Install

Datasheet

Download
Stealth for
OS X 10.3 installer

Stealth and Mac OS X 10.4 (Tiger)

Updated to version 1.4. Required for Mac OS X 10.4. For earlier versions of Mac OS X, please use version 1.1 or 1.2 (Panther).

The main benefit of the Stealth Serial Port is that it provides a "native" serial port that behaves just as if it was built-in the G4 or G3 system. With OS X, the Stealth provides that same level of compatibility - if it works with built-in serial port on a Beige G3 running Mac OS X then it will work with a Stealth.

 

Note - Apple has stated that LocalTalk will not be supported in OS X, so LocalTalk printers will not work with the Stealth under OS X (and under Classic). Also, your serial peripheral may require its own OS X drivers to work under OS X - please check with the vendor of your serial device. This update is not required for Mac OS 9.x users.

Download
Stealth for OS X 10.4 Installer (130K)

Home | Products | Support | Downloads | Company | Tutorials